Java for SkyView-in-a-Jar

Every now and then we receive emails from SkyView users reporting problems running the SkyView-in-a-Jar application (skyview.jar) on a local machine. Most of the time the problems are due to a mismatched version of java being used to run the command. When the wrong version of the java is used the error message typically includes the following error:

Exception in thread “main” java.lang.UnsupportedClassVersionError: Bad version number in .class file

We currently have two versions of skyview.jar, one for Java 1.6 (Java SE 6) and one for Java 1.5 (Java SE 5). If you are not sure which file to download you can determine the Java version from the Linux/Unix/OS X command line on your local machine by running:

java -version

Another problem a couple of users have encountered involves the use of gij, the GNU Interpreter for Java. At this time there seems to be an incompatibility between gij and the Skyview-in-a-Jar application. We are looking into this and hopefully will have this problem fixed soon. In the meantime it is advised that users install or switch to the Java interpreter provided by Sun Microsystems.

As always, if you questions about any aspect of SkyView please contact us.

This entry was posted in Discussion and tagged , . Bookmark the permalink.

4 Responses to Java for SkyView-in-a-Jar

  1. 680239139 Kid says:

    Will this run on Java 1.4?

  2. Tom McGlynn says:

    There is some fairly extensive use of generics in the SkyView code, so it cannot be compiled under Java 1.4 and it would probably take a fair bit of work to get it to do so. I’m afraid that you will need to upgrade to at least 1.5 to use one of the jars.

  3. Info Kepegawaian says:

    Will this run on Java 1.6?

  4. Laura says:

    Yes, it should. If you have any issues let us know.


Leave a Reply

Your email address will not be published. Required fields are marked *